Incident on our Asia data centers - network issue
Incident Report for
Eduka
Resolved
This incident has been resolved.
Posted
Jul
09
,
2026
-
04:03
UTC
Investigating
We are currently investigating this issue.
Posted
Jul
09
,
2026
-
04:02
UTC
This incident affected: Eduka Platform Hosting - Asia Cluster.
×
Subscribe to Incident
Subscribe to updates for
Incident on our Asia data centers - network issue
via . You'll receive .